设为首页收藏本站

中国OpenStack云计算社区

 找回密码
 注册
查看: 3211|回复: 4

建立keystone开发环境 [复制链接]

Rank: 7Rank: 7Rank: 7

发表于 2012-1-5 09:39:51 |显示全部楼层
需求:
       ·Ubuntu 11.10, Fedora 15, or Mac OS X Lion
       ·Python 2.7
安装以下工具包:
       git
       setuptools
       pip
获取最新的代码:
       $ git clone https://github.com/openstack/keystone.git
完成后,进入目录:
       $ cd keystone
安装依赖:
       Ubuntu 11.10:
       $ sudo apt-get install python-dev libxml2-dev libxslt1-dev libsasl2-dev libsqlite3-dev libssl-dev libldap2-dev

       Fedora 15:
       $ sudo yum install python-sqlite2 python-lxml python-greenlet-devel python-ldap

      Mac OS X Lion (requires MacPorts):
       $ sudo port install py-ldap
安装pip的依赖:
       # Describe dependencies (including non-PyPi dependencies)
       $ cat tools/pip-requires
       # Install all PyPi dependencies (for production, testing, and development)
       $ pip install -r tools/pip-requires
更新PYTHONPATH:
       # Fake-install the project by symlinking Keystone into your Python site-packages
       $ python setup.py develop
测试:
       >>> import keystone.version
       >>>
       获取keystone版本
       >>> print keystone.version.version()
       2012.1-dev

Rank: 4

发表于 2012-1-5 09:42:42 |显示全部楼层
不错,强势顶起

使用道具 举报

Rank: 7Rank: 7Rank: 7

发表于 2012-1-12 11:54:37 |显示全部楼层
   11.04也应该可以吧,还有对系统的位数有没有要求??

使用道具 举报

Rank: 7Rank: 7Rank: 7

发表于 2012-2-16 17:45:01 |显示全部楼层
整好需要,学习下

使用道具 举报

Rank: 7Rank: 7Rank: 7

发表于 2012-2-20 14:48:58 |显示全部楼层
我的keystone不能安装啊。是验证swift的

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

Archiver|China OpenStack User Group ( 鄂ICP备11010306号 )  网站地图

GMT+8, 2017-6-23 16:31 , Processed in 0.035100 second(s), 11 queries .

Powered by Discuz! X2

© 2001-2011 Comsenz Inc.

回顶部